Seite 2 von 3

BeitragVerfasst: 16.04.2008 12:51
von coccyx
so. guten tag. baue auch grad an einer s100.

@jumanji
hilfe benutzen, steht doch da ;)

kurzanleitung:
taget designer->config(slx) laden->bei components "Advanced Configuration and Power Interface (ACPI) PC"->settings->system pagefile..

ich hab als pagefile größe 128 mb angegeben und dann liess es sich installieren

BeitragVerfasst: 26.04.2008 13:24
von Wolfskin
Hallo Forum!

Ich brauch mal eure Hilfe da ich kurz vorm verzweifeln bin.
Ich Sitze seit 2 Nächten am Component Designer und versuche die Treiber in .sld Dateien zu packen. Soweit habe ich das hinbekommen und habe sogar 2 extra Pakete angelegt um Programme einzuspielen.
Ich bekomme immer aber auch wirklich immer beim Target buildig die Meldung, das die in den .sld Dateien angehängten Files nicht gefunden werden können.
Das eigentlich merkwürdige ist das im Wlan Treiber die .exe gefunden und ins Target kopiert wird aber die .sys und .inf Findet das System nicht.
Hatte gedacht das es evtl. an einer Zugriffsberechtigung liegt da er die nicht zu kopierenden Dateien aus dem Windowsverzeichnis liest. Ausführen als Admin hat auch keine Besserung gebracht. Muss ich die Treiber aus dem Windowsverzeichnis holen und den Pfad im Component Designer umlenken ?

Ach... ganz wichtig!! Die Datenbank ersetzt die .sld nicht sondern legt immer ne weiter an. Der Fehler hat mir 4 Stunden unnützes testen beschehrt.

Danke danke danke schonmal fürs helfen.

Gruß Wolf

BeitragVerfasst: 07.05.2008 14:30
von S100-Fan
Hi,

gibt es weitere User die über Ihre S100 und Windows XP Embedded berichten können?

Gruß.

BeitragVerfasst: 30.05.2008 14:09
von pogo
<!--QuoteBegin-S100-Fan+Mittwoch, 07.Mai 2008, 14:30 Uhr--></div><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (S100-Fan @ Mittwoch, 07.Mai 2008, 14:30 Uhr)</td></tr><tr><td id='QUOTE'><!--QuoteEBegin-->Hi,

gibt es weitere User die über Ihre S100 und Windows XP Embedded berichten können?

Gruß.[/quote]
XPe läuft bei mir auf der S100. Was möchtest du denn wissen?

BeitragVerfasst: 30.05.2008 15:49
von S100-Fan
<!--QuoteBegin-pogo+Freitag, 30.Mai 2008, 14:09 Uhr--></div><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (pogo @ Freitag, 30.Mai 2008, 14:09 Uhr)</td></tr><tr><td id='QUOTE'><!--QuoteEBegin--> <!--QuoteBegin-S100-Fan+Mittwoch, 07.Mai 2008, 14:30 Uhr--></div><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (S100-Fan @ Mittwoch, 07.Mai 2008, 14:30 Uhr)</td></tr><tr><td id='QUOTE'><!--QuoteEBegin-->Hi,

gibt es weitere User die über Ihre S100 und Windows XP Embedded berichten können?

Gruß.[/quote]
XPe läuft bei mir auf der S100. Was möchtest du denn wissen? [/quote]
Hi,

danke für die Meldung! :)

Ich habe mir das WinXP Embeddet geladen (war das ein Hürde!).

Leider fehlt mir im Moment die Zeit sich intensiv damit zu beschäftigen.

Bist du zu frieden mit dem System?

Funktioniert die Original-Fernbedinung?

Kannst du TV und VGA gleichzeitig nutzten?

Kannst du eine TV-Karte nutzen?

Wo sind Probleme aufgetraucht bei der Installtion und Konfiguration?

Gruß.

BeitragVerfasst: 01.06.2008 13:09
von pogo
<!--QuoteBegin-S100-Fan+Freitag, 30.Mai 2008, 15:49 Uhr--></div><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (S100-Fan @ Freitag, 30.Mai 2008, 15:49 Uhr)</td></tr><tr><td id='QUOTE'><!--QuoteEBegin--><!--QuoteBegin-pogo+Freitag, 30.Mai 2008, 14:09 Uhr--></div><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (pogo @ Freitag, 30.Mai 2008, 14:09 Uhr)</td></tr><tr><td id='QUOTE'><!--QuoteEBegin--> <!--QuoteBegin-S100-Fan+Mittwoch, 07.Mai 2008, 14:30 Uhr--></div><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (S100-Fan @ Mittwoch, 07.Mai 2008, 14:30 Uhr)</td></tr><tr><td id='QUOTE'><!--QuoteEBegin-->Hi,

gibt es weitere User die über Ihre S100 und Windows XP Embedded berichten können?

Gruß.[/quote]
XPe läuft bei mir auf der S100. Was möchtest du denn wissen? [/quote]
Hi,

danke für die Meldung! :)

Ich habe mir das WinXP Embeddet geladen (war das ein Hürde!).

Leider fehlt mir im Moment die Zeit sich intensiv damit zu beschäftigen.

Bist du zu frieden mit dem System?

Funktioniert die Original-Fernbedinung?

Kannst du TV und VGA gleichzeitig nutzten?

Kannst du eine TV-Karte nutzen?

Wo sind Probleme aufgetraucht bei der Installtion und Konfiguration?

Gruß.[/quote]

Die Installation von XP Embedded Studio unter Vista macht kleinere Probleme.
Falls du also Vista hast:
-als Datenbank solltest du den SQL Server 2005 Express Edition nehmen und die Service Packs installieren.
-Bei der Installation musst du als Instanzname MSSQLSERVER eingeben sonst geht es nicht

Bei der Installation vom XPe Image sind eigentlich keine Probleme aufgetreten - außer das ich vergessen hatte bei der Erstellung des Image die richtige Partition auszuwählen (auf der ersten Partition ist ein normales XP installiert, auf der zweiten XPe) und die Pagefile zu aktivieren.
Nachdem ich das korrigiert hatte lief der First Boot Agent durch und das System war installiert. Da konfiguriert sich dann alles automatisch.

Original Fernbedienung funktioniert problemlos.

TV-Karte habe ich noch nicht ausprobiert. Wenn du eine USB-TV-Karte hast sollte es kein Problem sein.

TV Ausgang habe ich ehrlich gesagt noch nicht getestet. Wenn du den i815-Treiber verwendest, sollte er funktionieren.

Ansonsten funktioniert alles (Audio, Grafik, WLAN, LAN)


Hier noch hilfreiche Links:
-sehr viele interessante Artikel (z.B. Dualboot, Erstellung von Komponenten, Anpassen der Shell,...):
<a href='http://msdn.microsoft.com/en-us/library/ms950428.aspx' target='_blank'>http://msdn.microsoft.com/en-us/library/ms950428.aspx</a>
-Tutorial Videos zu XPe:
<a href='http://msdn.microsoft.com/en-us/embedded/aa731297.aspx' target='_blank'>http://msdn.microsoft.com/en-us/embedded/aa731297.aspx</a>

BeitragVerfasst: 01.06.2008 17:11
von pogo
Nachtrag:
Hab meine KNC1 TV-Station DVB-C Karte eingebaut. Der BDA Treiber läßt sich unter XPe problemlos installieren.

Re: How to build a Windows XP Embedded System

BeitragVerfasst: 15.06.2008 13:48
von Cyberdelia
hilfffeeeeeeeee :)
also ich hab die s100 und hab das image gebastelt...
wenn ich es starte kommt dieser first boot agend wo die components installiert und dannach startet die kiste immer neu, auch im abgesicherten usw.
meine graka hab ich auch rausgemacht weil ich dachte wär ein irq prob aber pustekuchen.
selbe in grün.
hoffe jemand kann mir helfen.
gruß rené

Re: How to build a Windows XP Embedded System

BeitragVerfasst: 15.06.2008 23:36
von pogo
Hast du die Pagefile aktiviert?

Re: How to build a Windows XP Embedded System

BeitragVerfasst: 16.07.2008 11:41
von onkelalex123
ich habe eingentlich ein image hinbekommen ;), leider will mein Xpe nicht starten. Der kommt bis zum FBA läuft dann auch 1-2x durch, und irgendwann sagt das moppet mir, dass nicht genügend arbeitsspeciher vorhanden ist...

Pagefile habe ich auch im Target designer eingestellt :(

eventuell kann mir ja jemand mal seine fertige Taget designer datei schicken (funktionsfähig ;)), so dass ich mir das dann selbst bauen kann...

grüße alex

Re: How to build a Windows XP Embedded System

BeitragVerfasst: 03.08.2008 15:01
von pogo
Pagefile zu klein gewählt? Kein Platz auf der Festplatte für das Pagefile?

onkelalex123 hat geschrieben:ich habe eingentlich ein image hinbekommen ;), leider will mein Xpe nicht starten. Der kommt bis zum FBA läuft dann auch 1-2x durch, und irgendwann sagt das moppet mir, dass nicht genügend arbeitsspeciher vorhanden ist...

Pagefile habe ich auch im Target designer eingestellt :(

eventuell kann mir ja jemand mal seine fertige Taget designer datei schicken (funktionsfähig ;)), so dass ich mir das dann selbst bauen kann...

grüße alex

Re: How to build a Windows XP Embedded System

BeitragVerfasst: 05.08.2008 08:20
von bmafiaw
Na eine frage, wie kann ich z.b ein program wie winamp in mein XPe einbauen?
Beschaftige mich seit 1 woche mit XPe ober kann nicht ein program in XPe einbauen.
P.s ich will das ich z.b 10 programa einbaue und danach das niemand mehr Programe installieren kann.
Bitte um hilfe!!!

Re: How to build a Windows XP Embedded System

BeitragVerfasst: 05.08.2008 08:36
von bmafiaw
Jumanji7618: Sehe mal welche drivers deine Maus und Keyboard benuzen und vervende die Gleichen in XPe die meisten sind eingebaut!

Re: How to build a Windows XP Embedded System

BeitragVerfasst: 05.08.2008 10:59
von pogo
bmafiaw hat geschrieben:Na eine frage, wie kann ich z.b ein program wie winamp in mein XPe einbauen?
Beschaftige mich seit 1 woche mit XPe ober kann nicht ein program in XPe einbauen.
P.s ich will das ich z.b 10 programa einbaue und danach das niemand mehr Programe installieren kann.
Bitte um hilfe!!!


Du gehst so vor wie beim Erstellen neuer Treiberkomponenten:
http://msdn.microsoft.com/en-us/library/ms838332.aspx
Hier eine Schritt für Schritt Anleitung für WinAmp Lite:
http://blogs.msdn.com/embedded/articles/460335.aspx

Wenn man sich diese Seiten anschaut findet man alle notwendigen Informationen zu XPe:
-sehr viele interessante Artikel (z.B. Dualboot, Erstellung von Komponenten, Anpassen der Shell,...):
http://msdn.microsoft.com/en-us/library/ms950428.aspx
-Tutorial Videos zu XPe:
http://msdn.microsoft.com/en-us/embedded/aa731297.aspx

Re: How to build a Windows XP Embedded System

BeitragVerfasst: 06.08.2008 13:58
von bmafiaw
pogo kannst du mich bitte in Skype aufnemmen und mir 1 2 sachen uber XPe erklaren ich werde dir dankbar sein!
valsstar ist mein skype , auch wenn jurgend jemand etwas von XPe versteht :)